Issue installing PennMUSH on Genesis server

  • Pitcrew

    Hey there,

    My group and I are trying to install Penn 1.8.6 onto the GenesisMUDs servers for our game and the install is not unpacking properly. Here's the result we're getting when we try to make install

    cc1: error: unrecognized command line option "-fstack-protector"
    make1: *** access.o Error 1
    make1: Leaving directory `/home/mud/zetabeam/pennmush-1.8.6p0/src'
    make: *** all Error 2

    We've exhausted the Genesis troubleshooting FAQ and they haven't gotten around to contacting us yet after about a week. Anyone else run into this issue? Any ideas?

  • I suggest that you connect to, join the HardCode channel, and/or talk to Mike. He's one of the PennMUSH devs and if he can't help you, no one can.

  • Pitcrew


    Thanks, we'll give that a try

  • If you haven't gotten this yet, I think it's related to the GCC or PERL, as that's the only error notation for that specific line I can find. Make sure your GCC is the right version?

    EDIT: I asked for you.

    <Hardcode> [({<>})] Mike says, "For some reason, configure thinks your compiler knows that option but it actually doesn't. Open up your Makefile, there'll be a line starting with CCFLAGS= that contains -fstack-protector. Remove -fstack-protector from it and re-run make."
    Huh? (What's all this then?)
    <Hardcode> [({<>})] Mike says, "You might want to put a ticket up about it on github too, but off the top of my head I can't recall exactly what info you'd need to attach. Might just be your config.log file."

  • It's definitely a problem with GCC, maybe GenesisMUDS is using an ancient version? I'd be curious to know the output from 'gcc --version'.

  • Pitcrew

    It does indeed look like Genesis is running an older version of Linux on their server that is not compatible with newer versions of Penn. My head coder is looking for answers as well, so I'll update things here as I find out more.

Log in to reply