Removing Idle Limits?



  • Seems like TDM is bumping people off after 60 minutes of idling. I've tried Keepalive, but it still happens. Is there a setting somewhere on the game or hardcode to change that so it stops dumping folks off? Thanks!



  • @taika

    What's the codebase? Last time I was on a MUX, I had to set a timer client-side to send @@ every little while. It doesn't count as activity for the MU* but it does for the socket and so you don't get idledumped.



  • Knew I forgot something!>.> Sorry.

    MUX hey-thenomain-2016-04-18-12-g3e797bb
    hey-thenomain-2016-04-18-12-g3e797bb
    Builder: descent@TheDescentMUX
    Build time: Tue Sep 19 00:43:32 UTC 2017
    System: Linux TheDescentMUX 4.4.0-87-generic #110-Ubuntu SMP Tue Jul 18 12:55:35 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux


  • Coder

    MUX/TM3/Rhost: (Global Settings)
    @admin idle_timeout=-1

    Penn: (Global Settings)
    @config/set idle_timeout=0

    MUX/TM3: (individual)
    @power *player=idle
    @timeout *player=really-big-number-goes-here

    Rhost: (individual)
    @timeout *player=-1

    Penn: (individual)
    @power *player=idle


  • Coder

    Do note, on Rhost, changing the timeout only applies when the individual characters next connect -- the timeout is set on the connection itself so updating it doesn't update that value. This has confused the hell out of me in the past.


Log in to reply
 

Looks like your connection to MU Soapbox was lost, please wait while we try to reconnect.