Issue with IP config on PennMUSH

  • So, I've installed a PennMUSH server for myself on an Ubuntu system and FS3 Starter DB, everything was a success during installation, but I can't connect to my server using my public IP adress, only using the internal IP. The port was opened through iptables.

    Did I miss something? How can I fix that?

  • Do you have a router that does any incoming port restriction work?

  • No, it's configured so no ports are restricted.

  • Nevermind, it seems that my router had an additional firewall which was blocking communication, I was able to access and config it. Everything works as intended.

    Thanks for the help!

  • @sthanheykel Glad it was an easy fix!

  • Well, might be something else... I ran some tests with some friends and while I can use the WAN IP to connect to the server, no one outside the router's network can access it.

    I tried checking port forwarding, the port is allowed in all firewalls, but I still get no luck.

  • @sthanheykel Just for the sake of making sure it's not a typo (because god knows my brain has hiccuped enough in this sort of thing) ... it's not an inadvertent typo in iptables or the router?

  • Coder

    Are you on Frontier?

    I only ask because they block 90% of all incoming connections to your computer through their system. Regardless of how you have the connection setup. Especially if you're on the DSL. I had this problem when I had Frontier. Changed ISPs and with the same equipment the setup worked with no problems.

  • Tried a new router, reconfigured it all and everything works fine now.

    @Seamus No, I'm using Virtua, their services are very stable here so hopefully I won't have any problems with them :P

Log in to reply

Looks like your connection to MU Soapbox was lost, please wait while we try to reconnect.